Quick Start Guide

Overview

This page guides you through the setup and explains basic use of the Photo Tool. 

gINT

gINT must be installed and licensed on your computer to use the Photo Tool.  gINT Professional or Professional Plus are required to fully utilize this product.

gINT trial download and installation

Download gINT

Download the current release of gINT from https://softwaredownloads.bentley.com/ and log-in using your Bentley Select Username and password, for detailed instructions see How to download gINT from Bentley Website. 

If you need a trial installer of gINT, contact to sales@datgel.com.

Install and activate gINT trial

  1. Installation: 
    1. Ensure you are logged in as a local administrator, or have local administrator credentials ready to use.  Run the file gint########en.exe.
    2. The installation of Connection Client and gINT software starts.
    3. When the Custom Setup install wizard form appears, you should set "gINT Standard User Files" to "Entire feature will be unavailable".  This is the default.
    4. Select the gINT product Professional or Professional Plus
  2. Activation: Ensure you are logged into the Bentley Connection Client (program in system tray). If you don't have a Bentley Systems login, then register one. That could be done using a company email or a personal email.  That later will be a safe way to ensure your use of gINT is not later billed as a Quarterly Term License.

Open gINT

Company Information

First time you open gINT, the Company Information window will pop-up. Only the company name is required.

Later, you may access to this window in the menu Help > Company Information

System Properties

When you click OK in the Company Information window, the System Properties window will pop-up. In this window you store the general system properties.

File Location Defaults

The File Locations Defaults are used to quick save and access to the required gINT files folders. It is useful to configure the folders according your workflow.

  1. If you are trialling the software, you can select the Datgel product\gINT Files folder for all options. 
  2. If you are a gINT and Datgel product user, we recommend the following settings.
    1. Set Project Database and Drawings to the top of the folder hierarchy where you store project data
    2. Set Data Template, Scripts and Custom coordinate to the non-project specific folder on your file server, e.g. R:\gINT-Datgel\. Also store the library here.
    3. Check the box, Allow more than one user to open a file for editing.

Data Entry

  1. Check the box for Omit 'Must Save' prompt when save is required.
  2. Do not check European Numeric Format during Data Entry.  This feature causes errors with scientific notation fields and importing data.  Also ensue Windows has dot . for a decimal place.

gIDraw

If you cannot see the drawing cursor in drawing applications, then check Use small drawing cursor.

Output

  1. Set Unspecified Line Thickness (inches): 0.007
  2. Set Unspecified Point Thickness (inches): 0.01
  3. Set Number of digits to force sci. notation on frame divisions: 9
  4. Check Boundary Line inserted below last text segment at a depth.

DXF Files

No change.

General

  1. If you wish to use Database Design, Report Design etc., you must uncheck Hide Design Applications. This is unchecked by default. 
  2. You may like to adjust the Automatic File Backups option.

You may access to this form in the menu File > System Properties

Datgel Photo Tool Download

Download the Photo Tool package and Datgel Toolbox Installer:

Install Datgel Toolbox

Before Installation

A few basic preparations can help ensure an effortless installation.

  • Make sure that the computer where you plan to install the program meets the minimum hardware and software requirements.
  • Connect your PC to Internet before installation (the process may need a working Internet connection).
  • The Datgel Toolbox program requires that the Microsoft .NET 4.8 framework is installed on the PC prior to the installation of the Tool. If your PC does not have this, then it will be automatically downloaded and installed during the Tool installation process.
  • Log into the PC with Administrator privileges before starting installation.
  • It is recommended that you exit out of other applications that maybe running on your PC.
  • Close gINT before you start installation.

Installation

  • Run the installer, typically named Datgel.Toolbox.20##.#.#_YYYY-MM-DDTHHmmss.exe.
  • When you come to the Components screen, be sure to select this product, or you can simply install all Components. 

Datgel Licensing

Trial Version
  • Datgel's license system is based on a user identity that Datgel creates, based on your email address and name.  You would be asked to set a password at https://id.datgel.com/user/forgot/password.
  • At the time of identity creation Datgel would have assigned a persona license that only your user identity can use, which would expire normally after 14 days.
  • Datgel can also assign trial licenses to existing user identities that are members of an organization.
  • When you open the trial product library, the license check will be prompted.  Your default web browser will open and you will be asked to login.
  • The trial form will show each session, showing the count down to expire and links to purchase.
  • You can also see the status in the Datgel Licensing Manager app.
Full Version
  • Datgel's license system is based on a user identity that you would create after you your company's organization administrator would invites you via a email.
  • When you open the product library or otherwise first run the product in that session, the license check will be prompted.  Your default web browser will open and you will be asked to login.
  • You can also see the status in the Datgel Licensing Manager app.

Package Content

The Download .zip folder contains all you need to install and evaluate the Datgel Photo Tool. The content is:

  1. Documentation folder includes:
    1. Example reports
    2. EULA
    3. Links to the product online user guide
    4. Link to email to support.
  2. gINT Files folder includes:
    1. "dpt X.XX.X lib trial.glb" or "dpt X.XX.X lib.glb" (gINT library file)
    2. "dpt X.XX.X.gpj" (gINT project file)
    3. "dpt X.XX.X.gdt" (gINT data template)
    4. Sub-folders for each photo type:
      1. "dpt x.xx.x core photo"
      2. "dpt x.xx.x coro photo column"
      3. "dpt x.xx.x downhole image column"
      4. "dpt x.xx.x field sketch"
      5. "dpt x.xx.x photo"
      6. "dpt x.xx.x sample photo"
      7. "dpt x.xx.x vibrocorer photo"
      8. "dpt x.xx.x visual column"

Unzip and copy the content of the folder to your local computer.

Using the Tool

Open gINT

  1. Start gINT
  2. When you open gINT if it asked for a library, then browse to the extracted .zip folder and select the library file (.glb).  Otherwise after gINT opens select File > Change Library, and browse to the aforementioned library. Note: the library is locked for the Trial version.
  3. Select File > Open Project. Browse to the downloaded .zip folder and select the project file (.gpj)

Review existing example data

The gINT files included in the package contain example data that covers all type of reports included in the Tool.

Main Group | Point table stores the general information related to the Borehole (Hole depth, coordinates, elevation, etc). Each row is a borehole.

Main Group | Image table stores the image meta data for each Borehole. You can select the borehole by using the yellow drop-down list.

Options | Image Description table stores the image description configuration.

Naming the images and linking them to the boreholes using the Photo Tool Add-In

First you need to create a new PointID in the database. In this tutorial the example gINT files included in the tool are used.

  1. Go to POINT table and create 2 new PointIDs, as shown in the following screenshot.  New PointIDs are called example-borehole and example-trial-pit. Select CPC on the Visual Column for the example-borehole.
  2. Then, we need to add the images to the folders.
    1. From the files included in the package you have downloaded, browse to the folder gINT Files\dpt 3.04.1 core photo column. In this folder we will add the Core Photo Column. You can add your own files or copy the existing ones and rename them to:
      1.  example-borehole_00.00-01.00.jpg 
      2. example-borehole_01.00-02.00.jpg 
      3. example-borehole_02.00-03.00.jpg
    2. Now add images for the core box to the folder gINT Files\dpt 3.04.1 core photo. In this folder we will add the core box photos. You can add your own files or copy the existing ones and rename them to:
      1.  example-borehole_00.00-01.00.jpg
      2. example-borehole_01.00-02.00.jpg
      3. example-borehole_02.00-03.00.jpg
    3. Now we will add images for the trial pit to the folder gINT Files\dpt 3.04.1 photo. In this folder we will add the trial pit photos. You can add your own files or copy the existing ones and rename them to:
      1.  example-trial-pit_00.00-01.00.jpg
      2. example-trial-pit_01.00-01.25.jpg

  3. Once we have all images in the correct folder, we can run the add-in to link them to each borehole.
    1. First we will link the Core Photo Column images:
      1. Go to Add-Ins > Datgel Photo Tool > Datgel Photo Tool.
      2. Select the Folder: In the Add-in form, click on the button and browse to the folder where the images are stored.

      3. Select the Image Type: from the drop-down list, select CPC - core photo column
        At this point your add-in form should look like the following image:

      4. Click OK.
      5. New window will open with the summary and result of the link process.
      6. Click Close on the result window.
      7. You could close the form and view the data you just added.  Or keep it open to do the next linking operations.
    2. Now we will link the Core Photo Images:
      1. Select the Folder: In the Add-in form, click on the button and browse to the folder where the images are stored.

      2. Select the Image Type: from the drop-down list, select CPB - core box photo
        At this point your add-in form should look like the following image:

      3. Click OK.
      4. Click Close on the result window.
    3. Now we will link the Trial Pit images:
      1. Select the Folder: In the Add-in form, click on the button and browse to the folder where the images are stored.

      2. Select the Image Type: from the drop-down list, select TRP - test pit, exposure or traverse photo
        At this point your add-in form should look like the following image:

      3. Click OK.
      4. Click Close on the result window.
      5. Click Exit on the Datgel Photo Tool form.
    4. You can review the linked images in the Image table:



Output example

This section explains how to print reports using the reports included in the library.

Log report

The following example explains how to output the point example-borehole core and box photo log report. 

  1. First go to OUTPUT | Logs 
  2. Select the DG PHOTO VISUAL COLUMN AND CORE BOX A4P report from the yellow drop-down list.
  3. Select the desired PointIDs using the KeySet picker.
  4. Click on the  button and choose the name for new pdf document. Choose the location and click  Save. Choose resolution 600 dpi.
  5. Click  Export and review the report.

    You may add columns to these pages (e.g. soil description, samples, in situ tests, etc).
  6. Alternatively, click the    button to preview the report. You can review next page using the yellow drop-down list or press F6 button.

Graphic Table Test Pit

The following example explains how to output the Point example-trial-pit trial pit photo report.

  1. Go to OUTPUT | Graphic Tables
  2. Select the DG PHOTO TEST PIT PHOTO 2 PER PAGE A4P report from the yellow drop-down list.
  3. Select the desired PointIDs using the KeySet picker.

  4. Click on the  button and choose the name for new pdf document. Choose the location and click  Save. Choose resolution 600 dpi.
  5. Click  Export. In the User Report Variables you can add the information you  want to show in the report (optional). Click OK and review the report.
  6. Alternatively, click the    button to preview the report. You can review next page using the yellow drop-down list or press F6 button.

Graphic Table Core Photo

The following example explains how to output the Point borehole-example core box photo report.

  1. First, go to OUTPUT | Graphic Tables

  2. Select the DG PHOTO CORE PHOTO 1 PER PAGE A4L report from the yellow drop-down list.
  3. Select the desired PointIDs using the KeySet picker.
  4. Click on the  button and choose the name for the new pdf document. Choose the location and click Save. Choose resolution 600 dpi.
  5. Click Export. In the User Report Variables you can add the information you  want to show in the report (optional). Click OK and review the report.


  6. Alternatively, click the  button to preview the report. You can review next page using the yellow drop-down list or press F6 button.


On this page