Installation and Licensing

Installation Overview

There are four parts to the installation process:

  • Install Toolbox program
  • Licensing
  • Merge gINT library objects
  • Merge gINT project table to your project file and your data template

Datgel Photo Tool Download

Download the Photo Tool package and Datgel Toolbox Installer:

Package Contents

The package download from datgel.com which normally has the following folders: 

  • \Documentation
  • \gINT Files

Install Datgel Toolbox

Before Installation

A few basic preparations can help ensure an effortless installation.

  • Make sure that the computer where you plan to install the program meets the minimum hardware and software requirements.
  • Connect your PC to Internet before installation (the process may need a working Internet connection).
  • The Datgel Toolbox program requires that the Microsoft .NET 4.8 framework is installed on the PC prior to the installation of the Tool. If your PC does not have this, then it will be automatically downloaded and installed during the Tool installation process.
  • Log into the PC with Administrator privileges before starting installation.
  • It is recommended that you exit out of other applications that maybe running on your PC.
  • Close gINT before you start installation.

Installation

  • Run the installer, typically named Datgel.Toolbox.20##.#.#_YYYY-MM-DDTHHmmss.exe.
  • When you come to the Components screen, be sure to select this product, or you can simply install all Components. 

Datgel Licensing

Trial Version
  • Datgel's license system is based on a user identity that Datgel creates, based on your email address and name.  You would be asked to set a password at https://id.datgel.com/user/forgot/password.
  • At the time of identity creation Datgel would have assigned a persona license that only your user identity can use, which would expire normally after 14 days.
  • Datgel can also assign trial licenses to existing user identities that are members of an organization.
  • When you open the trial product library, the license check will be prompted.  Your default web browser will open and you will be asked to login.
  • The trial form will show each session, showing the count down to expire and links to purchase.
  • You can also see the status in the Datgel Licensing Manager app.
Full Version
  • Datgel's license system is based on a user identity that you would create after you your company's organization administrator would invites you via a email.
  • When you open the product library or otherwise first run the product in that session, the license check will be prompted.  Your default web browser will open and you will be asked to login.
  • You can also see the status in the Datgel Licensing Manager app.

Merge gINT Library Objects

In the trial version of the Photo Tool, the library will be locked and you cannot merge any gINT Library Objects into your Library file, or make changes to this Library file. In this case, you have to use the locked library as-is.


If you have purchased the Photo Tool, then you have full access to the library objects, and you may proceed with the following steps to merge the gINT Library components into your Library file.

If you are currently using an AGS RTA type database you should delete old AGS RTA related tables and merge the new DGD tables.

If you are upgrading, best to delete all old related fields and tables from the library and project, and merge the new ones.

  1. Make a backup copy of your existing library file. By default this is located in: C:\Users\Public\Documents\Bentley\gINTCL\libraries
  2. Extract the gINT Files folder from the downloaded .zip folder to your PC or a file share.
  3. Start gINT and open the library and project file you wish to use with Datgel Photo Tool.
    The opened project and library files are displayed at the top of the gINT Window.
  4. Select UTILITIES | Lib Merge/Copy.
  5. Check the bullet that reads Merge from.
  6. In the Source Library File pane, browse to the gINT Files folder (that you previously copied from the downloaded .zip folder to your Desktop) for the file Datgel Photo tool DGD #.## lib.glb where ## is the version number. 
  7. Check the bullet that reads Select All.
  8. Check the bullet that reads Query on Overwrite.
  9. Click button to move all tables from the Available Source Tables pane on the left to the Tables to Merge/Copy pane on the right side.
  10. Click Execute.
    Take care to read the overwrite dialog and click Yes if you wish to overwrite the file, ELSE click No.

    This will merge in the Add-In menu item, Image Type lookup list, gINT Rules modules, graphic tables, log reports and user system data, which are all related to the Tool.
  11. Click OK to finish the merge.

Merge gINT Project Tables and Fields

  1. Make a backup copy of your existing project file. By default this is located in: C:\Users\Public\Documents\Bentley\gINTCL\Projects\
  2. Start gINT and open the library and project file you wish to use with Datgel Photo Tool.
  3. Select DATA DESIGN | Project Database.
  4. Select File > Open File > Current Project… to open your current project file.
  5. Select Tables >Import Multiples Tables... then browse to the gINT Files folder (that you previously copied from the .zip file) and select the file Datgel Photo Tool DGD #.##.gpj where #.## is the version number.
    Click Open.
    Merge the tables IMAGE, IMAGE_DESCRIPTION and PROJECT_OPTIONS.
  6. If and PROJECT_OPTIONS exists, then Select Tables >Merge Fields from Other File... then browse to the gINT Files folder (that you previously copied from the zip file) and select the file Datgel Photo Tool DGD ##.#.gpj. Select the PROJECT_OPTIONS table, and select all fields.
  7. Similar to step 6, merge PROJECT.Office and POINT.Visual_Column.
  8. Select INPUT | Main Group to review the new IMAGE and the order appears in gINT INPUT can be changed in the Tables > Input Sequence… menu option.
  9. In the Options | IMAGE_DESCRIPTION table is empty, import data from Datgel Photo Tool DGD ##.#.gpj for this table only.
  10. Select Tools > Make Data Template to either create a new data template, or write over an existing one to ensure your data template has the new table. Click Save.
  11. Once you have completed the above steps you can now delete the gINT Files folder that you previously copied onto your Desktop.

Configuring Logos in the Library

Import a new raster file

Logos images are managed from SYMBOL DESIGN | Bitmap Symbols.  You can store many different logos here, each having its own page.  Non logo images can also be stored here.

Make a new Bitmap Symbol

  1. Create a new page
  2. Enter the Name and Description.
  3. Using the Load Raster File browser, select the file you wish to import, and click OK.

Replace existing Bitmap Symbol with a new image

  1. Select the item from the object selector list
  2. Open Page Properties
  3. Using the Load Raster File, browser, select the file you wish to import, and click OK.

How to add a new Office

  1. If required, import the raster file as described in section Import a new raster file.
  2. Navigate to DATA DESIGN | Library Data, and open table DG_COM_OFFICE.

    DG_COM_OFFICE
  3. Make a new record and update the Office, Engineer_Logo, Figure_Logo, and Figure_Logo_X_Offset fields.
  4. Return to INPUT, and on the Project table select new item in the Office field. If you prefer to use the new office for your projects, set it as the field default, and make a new data template.
  5. Move to OUTPUT, and test that log and graph reports present the logo as desired. You might need to adjust the value for Figure_Logo_X_Offset to present the logo cantered in the figure title block box. Keep in mind that by default the logo will be offset by 2 mm.

On this page